AA AlertXpress Website event
Incident Report for Equifax Workforce Solutions
Resolved
This incident has been resolved.
Posted Jan 08, 2020 - 07:17 EST
Investigating
We are experiencing a service interruption to the AA AlertXpress website. The Appriss Safety Engineering Team is investigating the issue and working toward its resolution.
Posted Jan 08, 2020 - 06:36 EST
This incident affected: Programs - American Airlines (AA AlertXpress Website).